FV Community News Upgrader

Version 3.0 and later of the Community News plugin will not be backwards compatible with version 2 and earlier. But you might have a lot of posts already that will be lost if you choose to update the plugin. To help you with the update, I made a little plugin that helps you converting all of the old posts to work with the new version.

Instructions

The first thing you should do is uninstall the old version. You can safely check the remove settings option, but do not check the remove data option! Then confirm the uninstall and click the uninstall button.

After you have removed all the files from the old version, install version 3.0 or later and activate it.

When the new version is active, you can install the upgrader plugin. Download it, upload it to your wp-content/plugins/ folder and activate it. After it is activated, there will be a new admin page: Community News → Upgrader.

On that admin page is an option to delete the old posts after they have converted. If you do not check it, you will have to delete the old posts later using phpMyAdmin or a similar database tool. But if you do check it and something does go wrong, your posts will be lost.

Click the upgrade button to start the conversion of your posts. Keep in mind that this is a very heavy process for your server, and that your blog will be put in maintenance mode while the upgrader is running.

When the upgrader is ready, you can delete the upgrader plugin. Your old posts will now be available in the new version! That’s all!

Download

Version: 1.0
Download: FV Community News Upgrader

Need more help? Let me know!

Wordpress Plugins
,