New JavaScript Used

Hey everyone.

After adding version 1.3, I received a few notifications about the javascript. It gave errors, wasn’t compatible with most plugins and/or themes and just sucked 🙂

My decision was to update the complete javascript used with version 2.0, since that one is going to have a complete makeover. However, more and more emails came, telling about the JavaScript. The problem seems to be worse then I was thinking, so an early patch for the javascript is already available.

I removed the Prototype framework for compatibility, since most themes and plugins are using jQuery. Now the Community News plugin does too. It uses the jQuery lib that comes with WordPress itself. I hope this will improve the compatibility. Also errors which occurred in the old javascript are fixed.

Wordpress Plugins
, ,